Lonworks Diagnostic tool: Node Util

-Would you like to know the neuron id of your Lonworks device/s?

-Would you like to find out the subnet and the program ids for your lonworks device/s?

Node Util is a completely FREE tool made available by Lonmarks for diagnosis of Lonworks networks and devices.

Downloads:

-Node-Util User guid (pdf)

-Node-Util installer package (includes the executable)

Introduction:

The NodeUtil Node Utility is a test and diagnostic tool that can be used with Echelon’s family of network interfaces (including the PCLTA-20, PCLTA-21, PCC-10, i.LON® 10, i.LON 100, i.LON 600, i.LON SmartServer, SLTA-10, U10, and U20 network interfaces). It is a is a console application for Microsoft® Windows® systems. NodeUtil Node Utility can be used to diagnose and configure LONWORKS® network interfaces, routers, and devices.

Using Node-Util it is only possible to view and modify the configuration of a single device, it is not possible to manage a device’s configuration in the context of the network containing the device.

Important: Using NodeUtil, it is possible to make a device inoperable, so that it no longer communicates with other devices in its network. Certain operations, such as modifying communications parameters to incorrect values, can cause an unrecoverable device failure. The NodeUtil Node Utility is provided as an UNSUPPORTED software tool.

PC Hardware Requirements to install Node-Util

The following are minimum requirements:

  • Intel® Pentium® III 366 MHz processor
  • 128 MB RAM
  • 10 MB of available hard-disk space
  • 800x600 screen resolution
  • An Echelon LONWORKS network interface—the PCLTA-20, PCLTA-21,
  • PCC-10, i.LON 10, i.LON 100, i.LON 600, i.LON SmartServer, SLTA-10,
  • U10, or U20 network interfaces
  • An Internet Protocol (TCP/IP) compatible network interface (if you are
  • using an i.LON 10, i.LON 100, i.LON 600, or SmartServer network
  • interface)

PC Software Requirements

The following are minimum requirements:

  • Microsoft Windows XP or 32-bit version of Windows 7, Windows Vista® or Windows Server 2008
  • OpenLDV 3.3C or later
  • Appropriate Echelon network interface driver (if you are using an SLTA-10 or LTS-20)
  • Windows TCP/IP software (if you are using an i.LON 10, i.LON 100,i.LON 600, or SmartServer network interface)